Skip navigation
879 Views 5 Replies Latest reply: Mar 9, 2012 6:54 AM by FrankS.Schiavone RSS
ptc-2090400 Copper 4 posts since
Oct 28, 2008
Currently Being Moderated

Mar 9, 2012 3:10 AM

Out of Range Issue

I am having an issue with extruded wall thicknesses having a lower limit.  I am simply trying to extrude a section and give it a wall thickness, using the command within the extrude feature rather than the sketch.  On occasion, not always, this gives me an error saying that the size I type in is out of range, for example on the attached screen shot I was trying to give a 50x30mm piece of section a 3mm wall, the note popped up saying the minimum thickness is 3.07mm.  I have spoken to my VAR and they have been no help, I even sent them a sample and a copy of my Config.pro and they can't replicate the problem.  The funny thing is that if you then edit the thickness by double clicking within the graphics window the thickness can be what is required.

 

Anybody got any thoughts?

 

Thanks

 

Tim

Attachments:
  • John.Pryal Gold 305 posts since
    Jun 27, 2007
    Currently Being Moderated
    Mar 9, 2012 4:12 AM (in response to ptc-2090400)
    Re: Out of Range Issue

    Hi Tim,

              judging by the example shown, i'd say it could be an accuracy problem, try making the accuracy of your part a little tighter.

     

    Regards

     

    John

  • SushantaDas Copper 5 posts since
    Jul 6, 2011
    Currently Being Moderated
    Mar 9, 2012 4:18 AM (in response to ptc-2090400)
    Re: Out of Range Issue

    Hello Tim Wood,

     

    I know the best answer to this problem.

    Go to Set up > Accuracy and change the part accuracy to 0.001.

    Then try adding the thickness. It will surely work.

     

    Let me know if this issue is resolved.

     

    sDas

  • SushantaDas Copper 5 posts since
    Jul 6, 2011
    Currently Being Moderated
    Mar 9, 2012 4:33 AM (in response to ptc-2090400)
    Re: Out of Range Issue

    If your problem is not solved can u please attach the part for further investivation.

    sDas

  • FrankS.Schiavone Platinum 1,185 posts since
    Sep 8, 2011
    Currently Being Moderated
    Mar 9, 2012 6:54 AM (in response to ptc-2090400)
    Re: Out of Range Issue

    For parts like this that have a large difference between the largest face and the smallest face, you need to enable "absolute" accuracy instead of the default "relative" accuracy.  Set "enable_absolute_accuracy" to "yes".  Then, change it to maybe .0001.  That should solve the issue.

     

    Relative accuracy is just that, the size of the largest face relative to the smallest.  This default setting results in smaller files, but you run into these problems.  I use absolute almost exclusively.  And, the best thing is, if you know you'll be doing really complicated geometry or long thin geometry, set the absolute accuracy BEFORE creating any model geometry as this can actuall cause previous features to fail.

     

    Good luck!

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 3 points
  • Helpful Answers - 1 points